1.6.3以前のバージョンのGO言語を使っている人は MacOS Sierraにアップグレードしないほうがいい話

こんにちは yoshi です。

今日Sierraにアップグレードしたのですが、急にgoプロジェクトのコンパイルができなくなりました。 原因を追求したところ、新しいOSであるSierraでは1.6.3より前のバージョンのものは使えないそうです。

公式HPによると

Go 1.7 adds support for macOS 10.12 Sierra. This support was backported to Go 1.6.3. Binaries built with versions of Go before 1.6.3 will not work correctly on Sierra.  

とされ、SierraでGOを使いたい場合は1.7にバージョンアップを余儀なくされます。

ということで、Macをお使いの方は気をつけましょう。